EF(EntityFramework)与mysql使用,错误终极解决方案

2019-10-07 20:45栏目:www.70570.com
TAG:

 

 

我昨天写了好多篇跟mysql有关的错误,但是在今天我发现好像所有的问题都是一个原因引起的:

EF(EntityFramework)与mysql使用,错误终极解决方案。版本问题,我原先使用的是MySql.Data.Entity.EF6(版本号:EF(EntityFramework)与mysql使用,错误终极解决方案。EF(EntityFramework)与mysql使用,错误终极解决方案。6.10.5),今天我换成EF(EntityFramework)与mysql使用,错误终极解决方案。EF(EntityFramework)与mysql使用,错误终极解决方案。6.9.10版本后上述的问题就有很少发生了。

建议大家,如果按照我上述的方案无法解决自己的问题,那么大家把MySql.Data.Entity.EF6和MySql.Data的版本降下来,安装6.9.10版本试试。

 

还有一种报错,报错信息:

System.IO.FileLoadException:“未能加载文件或程序集“MySql.Data, Version=6.9.10.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d”或它的某一个依赖项。找到的程序集清单定义与程序集引用不匹配。 (异常来自 HRESULT:0x80131040)”

虽然我装的mysql版本是6.9.10,web.config中的版本号也是6.9.10。

图片 1

如图所示,虽然一致但是也报错,但是我改成了

图片 2

这样就没有问题了,没有报错了。只对本地有效,发布到服务器上的话,版本号就要一致才行。

这是我平常遇到的问题及解决方案。

 

版权声明:本文由威尼斯手机娱乐官网平台发布于www.70570.com,转载请注明出处:EF(EntityFramework)与mysql使用,错误终极解决方案